Jump to content

Welcome to TrollGame Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Photo

**TG_Captain_Battle** Event with new features


  • Please log in to reply
50 replies to this topic

#21
LizardWizard

LizardWizard

    Ancient Member

  • Senior Ex Staff
  • 693 posts
  • LocationOz

the 1st 2 rounds were good playability,but now everyone's ping went to 3 times more and ofc,everyone is having severe lag.

That smells like ddos.



#22
Chivalrous_Roamin_Knight

Chivalrous_Roamin_Knight

    Night's Guardian

  • Senior Admin
  • 462 posts
  • LocationUnited States,Ohio

That smells like ddos.

What's that mean? I saw Joss posted in Shoutbox that too. Can it be fixed? Hmmm, I'm still on there now, and pings r near normal again. Right now, I'm in spec. Will see how things go. Hmmm, looks like after the 1st battle, pings sky rocketed again.


Edited by Chivalrous_Roamin_Knight, 03 April 2018 - 09:41 AM.

My Youtube Channel of TG Warband Content:
https://www.youtube....GOMiKUmeWO0DJIA

#23
LizardWizard

LizardWizard

    Ancient Member

  • Senior Ex Staff
  • 693 posts
  • LocationOz

What's that mean? I saw Joss posted in Shoutbox that too. Can it be fixed?

It means some wise guy is trying to bring the server down or slow it to a crawl by flooding it with a large number of requests.

We've dealt with this before and all the measures that we could take are already in place. There's not much else to be done.



#24
Chivalrous_Roamin_Knight

Chivalrous_Roamin_Knight

    Night's Guardian

  • Senior Admin
  • 462 posts
  • LocationUnited States,Ohio

It means some wise guy is trying to bring the server down or slow it to a crawl by flooding it with a large number of requests.

We've dealt with this before and all the measures that we could take are already in place. There's not much else to be done.

Ok, thanks. The bots seem not to be lagging, just the players themselves....at least, me and the ones who have said in chat, so I assume all the players are as their ping shows.

Wow...I'm in spec and a player kicks me off...what the heck!!!? Ok, maybe everyone got kicked? Unsure, but no players are here now. Even being in spec my ping even right now is 364, normally it's in the 130's and on the other TG servers.


Edited by Chivalrous_Roamin_Knight, 03 April 2018 - 09:51 AM.

My Youtube Channel of TG Warband Content:
https://www.youtube....GOMiKUmeWO0DJIA

#25
Lenna

Lenna

    Popular Member

  • Member
  • 65 posts

Lastly, the server spat out some script error codes (which doesn't happen too often) during the Hastings map.

That probably eats some extra CPU for nothing. It should be looked into.

It happened at around 8 PM GMT +0 (searching the logs for case-sensitive "OP" or "script" might prove helpful).

 

Check the rgl_log.txt file in your main Warband game folder. Some of the client-side invoked SCRIPT ERROR ON OPCODE messages and crashes in general are being recorded there. That file is/was being constantly re-written, so it's generally good to make a backup right after you experience a crash or an error; at least from my experience.


  • BlackDeath, LizardWizard and Helgisa like this

#26
LizardWizard

LizardWizard

    Ancient Member

  • Senior Ex Staff
  • 693 posts
  • LocationOz

Check the rgl_log.txt file in your main Warband game folder. Some of the client-side invoked SCRIPT ERROR ON OPCODE messages and crashes in general are being recorded there. That file is/was being constantly re-written, so it's generally good to make a backup right after you experience a crash or an error; at least from my experience.

Fortunately for me, I haven't played since then. Found the errors. Thanks for the tip.

Spoiler

  • BlackDeath and Lenna like this

#27
Chivalrous_Roamin_Knight

Chivalrous_Roamin_Knight

    Night's Guardian

  • Senior Admin
  • 462 posts
  • LocationUnited States,Ohio

Played the server from now till the last maybe 5 or 6 maps and everything seemed almost perfect; no high pings happened, no lag (from my pc). Only a few problems I had: Once I respawned with only a horse, armor but no weapons; a few times my unit would not obey the charge command, the Fire At Will command (this happened twice) and other commands seemed to work; also, I got a Script Error message when I jumped on the catapult after I respawned as the infantry class (I was initially of the Archer class).

It happened after I hit the Right Shift key; I wanted to be sure that's what generated the code, so I jumped off then on it again and hit the Right Shift key, and again, the error generated. Thanks for a interestingly fun server. I will continue to report things as I experience them or hear from other players' comments or issues. Here is the screen shot of that Script Error:[attachment=755:mb_warband 2018-04-04 05-20-49-506.jpg]


My Youtube Channel of TG Warband Content:
https://www.youtube....GOMiKUmeWO0DJIA

#28
KingArthur

KingArthur

    Ancient Member

  • High Admin
  • 953 posts
  • LocationItaly

The errors reported by you and lizard happen when you try to use neogk features after respawning as a bot. Both are on client side. Even if i fix it, all would have to update neogk.


  • BlackDeath, LizardWizard and Chivalrous_Roamin_Knight like this

#29
Helgisa

Helgisa

    Elite Member

  • Member
  • 102 posts
  • LocationFalling down from a cloud

Just wondering, does kills and deaths of a players bots get added to the respective players kills and deaths?

 

I can't figure out any other reason for me to die twice a match and get 17-ish additional deaths on my death counter  :huh:



#30
KingArthur

KingArthur

    Ancient Member

  • High Admin
  • 953 posts
  • LocationItaly

Just wondering, does kills and deaths of a players bots get added to the respective players kills and deaths?

 

I can't figure out any other reason for me to die twice a match and get 17-ish additional deaths on my death counter  :huh:

 

Yes.



#31
Helgisa

Helgisa

    Elite Member

  • Member
  • 102 posts
  • LocationFalling down from a cloud

Yes.

 

Aaah, okay =)



#32
LizardWizard

LizardWizard

    Ancient Member

  • Senior Ex Staff
  • 693 posts
  • LocationOz

I have to say, the lag seems to have gone. Aside from the usual bots 20 meters above ground, floating in the air, everything seems to be working smoothly.

I don't know what you did but nice job.


  • BlackDeath, Aratar and Chivalrous_Roamin_Knight like this

#33
Chivalrous_Roamin_Knight

Chivalrous_Roamin_Knight

    Night's Guardian

  • Senior Admin
  • 462 posts
  • LocationUnited States,Ohio

I have to say, the lag seems to have gone. Aside from the usual bots 20 meters above ground, floating in the air, everything seems to be working smoothly.

I don't know what you did but nice job.

Totally agree with you! I played more maps than I really should've late last night and into my early morning hours (U.S. time), I really needed to go to bed, but couldn't stop playing. :P

Only issues I had were sometimes my troops wouldn't Fire At Will or Charge; I made sure I was pressing the right troop command when I saw this happening (this was pretty rare, still tho happened). Other issue I can say of: at times my own avatar couldn't DO anything; wouldn't fire my xbow or even load it, wouldn't switch weapons until after some time then when it would switch my hammer wouldn't swing. I also experienced NO lag when this would happen. I could move and command fine, which is what I resorted to do when I realized what I couldn't do. (Which should be most of what the objective of the server is anyway, but not all ofc)

Also, trying to remember what other players were saying in chat they were having issues with; don't remember what was said if anything, right now, other than two things: 1 that was mentioned (The equipment of troops were not equipped with what they chose or an omission of a weapon was happening, as in 1 instance with my troops, they had no hammer (no melee weapon) and 1 that was observed: (Players were not able to spawn because the round was starting sooner than the equipping of a player was finished; you could see they joined as by the C screen, but remained their name in red (not spawned).

 

Last thing that happened with me: In a round after the previous round, only my character was equipped with 2 xbows and bolts but no other weapon as my troops were loaded as I selected. It could be, that I picked up (F key) an xbow during the previous round on the last respawn of that round; I don't think that's what happened tho. My troops weren't equipped like I was.

Maybe, when a round starts, it's a hit or miss what the troops equip with as far as what your character has in the round previous; I say this, because my xbow carrying character found a horse and decided to mount it right before the round ended and when the next round started, my troops were now an all mounted xbow unit. :P Another time I did that very same thing, this time tho, none of my troops were mounted :angry: just only my character was :mellow: .

I have seen in chat, players are enjoying this mode......Great thot and undertaking, KingArthur and White Potato!! And any others too!!!!

Saluti!


  • Aratar likes this
My Youtube Channel of TG Warband Content:
https://www.youtube....GOMiKUmeWO0DJIA

#34
BlackDeath

BlackDeath

    The Mongol

  • High Admin
  • 6,073 posts
  • LocationFlying around in space

I want post here this same info already posted in a ban-topic about insults/bad words between players in same team, to be fair:

 

"A Warn:

 

New Battle (**TG_Captain_Battle**) is for an even more cooperative game mode in team, so any other "similar" bad behavior/attitude between members of the same faction, will be punished."


  • Chivalrous_Roamin_Knight likes this

#35
KingArthur

KingArthur

    Ancient Member

  • High Admin
  • 953 posts
  • LocationItaly

Some bad news about fixing those problems reported by chiv:

  • i don't think is possible to fix the wrong horse bug. While the game gives me the possibility to sync the equipment, the horses can't be changed "on the fly". I would have to spawn a horse and make the agents mount that new horse, too weird.
  • impossibility to change weapon or attack. Does it happen even with few players and bots ? I remember a similar problem on siege with many players where i wasn't able to see the animation of my attacks.
  • flying bots, same as above, does it happen with few players/bots ? Even if isn't there's nothing i can do. It looks like a game rendering glitch.
  • give more time at start of round. The code that does this seems hardcoded. These's the code running after a player is spawned but the pre-spawn code seems not present.

These problems can be considered not fixable. If you've any idea how to fix them, feel free to write.


  • Chivalrous_Roamin_Knight likes this

#36
BlackDeath

BlackDeath

    The Mongol

  • High Admin
  • 6,073 posts
  • LocationFlying around in space

Some bad news about fixing those problems reported by chiv:

  • impossibility to change weapon or attack. Does it happen even with few players and bots ? I remember a similar problem on siege with many players where i wasn't able to see the animation of my attacks.
  • flying bots, same as above, does it happen with few players/bots ? Even if isn't there's nothing i can do. It looks like a game rendering glitch.

 

similar things happened/happens sometimes in siege, more since new battle started.. :(

...maybe because stressed cores?



#37
Samot

Samot

    Newbie

  • Member
  • 5 posts

Getting issues with not having the correct gear last night. I was giving my soldiers torches and war darts, and they were only getting the war darts.



#38
Samot

Samot

    Newbie

  • Member
  • 5 posts

and constant issues with downgrading gear when cost is well under 1600



#39
KingArthur

KingArthur

    Ancient Member

  • High Admin
  • 953 posts
  • LocationItaly
@Samot,those issues should get fixed in next update.
@Black, i don't know. By what i've seen the cores are already redistributed automatically. Maybe we're reaching the server bandwidth limit.
  • Chivalrous_Roamin_Knight likes this

#40
BlackDeath

BlackDeath

    The Mongol

  • High Admin
  • 6,073 posts
  • LocationFlying around in space

@Samot,those issues should get fixed in next update.
@Black, i don't know. By what i've seen the cores are already redistributed automatically. Maybe we're reaching the server bandwidth limit.

well yes, I mean some like this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users